Access Denied error while using the webpart

Jul 21, 2008 at 1:55 PM
Hi
I am getting the following error while trying to add the webpart to the search page.

"Unable to add selected web part(s).

Wildcardsearch Core Results Web Part (DotnetMafia.com): could not load file or assembly "DotnetMafia.office.Server.WildCardSearch,version=1.0.0,Culture="neutral" or one of its dependencies. Accesss is denied"

My sharepoint admin says he has given full permissions to me. Is there anything else needs to be done here to use the web part?

Thanks,
Ramana
Jul 28, 2008 at 4:26 AM
Hi,

I am having the same problem as above.
Does anyone know how to get past it??
I am an administrator with full access to the server (dev environment).

Thanks,
Atilia
Apr 27, 2009 at 1:25 AM
Was there a resolution to this error?  I am getting the same thing.
May 21, 2009 at 12:34 AM

you need to run iisreset after installing the solution

Coordinator
May 26, 2009 at 7:34 PM

Also make sure that you have .NET Framework 3.5 installed.  Check the web part gallery and see if you can preview the web part there.

Jul 29, 2009 at 7:14 AM

Hi cdog,

I have the same error message. Farm install, .NET 3.5 installed, IIS reset. I cannot view the web part from the gallery. Not really sure what it is. Anyone got any ideas?

Jan 8, 2010 at 10:58 AM

Hi,

I installed it with WSS 3.0 and Microsoft Search Server 2008 Express and had the same problem.

Step 2 and 3 in kpriemer's post from Jul 9 2009 at 11:00 in discussion http://wildcardsearch.codeplex.com/Thread/View.aspx?ThreadId=52085 solved the problem in my case:

  • Go to your Homepage, Website Settings, Webparts (Webpartcatalog), Klick "New", check the overwrite option and (in my case first entry in the list) the "DotNetMafia.Office.Server.Search.WildcardSearch.WildcardSearchCoreResultsWebPart" and click the buttom on the top of the page (Something like "Fill up Catalog", my Installation is in german and I do not have the english Text for the button present)
  • Go to your Searchresult page as described, you'll find two Webparts for Wildchard Search. In my case the webpart without "DotNetMafia.com" in Brackets is working, the other one throws a .NET Error as described in a different Post here.